SYMPTOM
You followed the directions in Activating Your Bamboo Product License successfully activated your license. However, when you go to a page where the web part is used you see a license error:
CAUSE
If this happens immediately after successful activation, the error is typically that one or more WFE servers on the farm do not have an activated license. If you are sure all servers have been successfully activated, another cause could be that a trial extension file (.lic) remains on one of the WFE servers in the farm and is causing a conflict.
If the license error happens after you have been using your activated product for some time, the cause for the issue could be that the hardware profile of one of your WFE servers has changed. Bamboo product licenses are tied to the hardware profile. If that profile changes (i.e., you add a new hard drive), the license needs to be re-activated. See How to move your Bamboo Product License to a new server for resolution information.
RESOLUTION
Confirm that there are no Bamboo trial extension files (Bamboo.lic) on the any of the WFE servers. Follow these steps:
Step | Action |
---|---|
1. | From the SharePoint server, use Windows Explorer to drill down the inetpub folder structure to locate and access the appropriate virtual directory for the web application where the license error appears. |
1. | Locate the ‘bin’ folder where the Bamboo product’s DLL should be found. |
1. |
Search for files that start with “Bamboo” and have a .lic extension. If one exists for the product with the license issue, delete it.
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