Overview of the new Bamboo product Logging
In April 2017, Bamboo released Bamboo.Logging v3.1.0.0 with the Q1 (2017) Cumulative Update of Bamboo component products.
In response to customer feedback the new logging version uses SharePoint ULS logs by default, instead of the the Bamboo logs. The main benefits of this change are:
- Bamboo Log files will not fill the C: drive on WFE servers. Previously, Bamboo products reported errors to proprietary log files located in C:WindowsTempBambooSolutions on each web front end server in the farm as described in Error Log Files.
- SharePoint administrators are very familiar with ULS logs and the ULS Log Viewer. When Bamboo products log to ULS, SharePoint administrators have one less set of logs to review.
- ULS log files can be more easily managed for size and archived, a feature that was not previously available for Bamboo logs.
Bamboo component products installed or upgraded after April 2017 will have the new Bamboo Logging deployed as part of the Bamboo.Framework.wsp solution, which is common to Bamboo products and globally deployed to the SharePoint farm.
IMPORTANT:
1) If you have multiple Bamboo products installed on your farm, some Bamboo log files may remain in C:/Windows/Temp/BambooSolutions until you upgrade all of the Bamboo products.
2) Bamboo applications (e.g., PM Central, Workflow Conductor, In/Out Schedule Board) will not have the new Bamboo Logging until their respective CU’s are available in Q2 2017.
Please note the following for the new scripts:
The script installs all the WSPs found in the installation folder, in alpha order
The install/upgrade script deploys to all content web apps. If you would prefer to deploy to a single web app, you can modify the script or deploy via Central Administration.
Uses Upgrade instead of Install for existing components.
For additional information about how to use the updated processes:
Installing using the updated install process
Upgrading using the updated process
Uninstalling using the updated process
File Share Library Limitations
The following limitations apply to Video Library when it is connected to a File Share Library:
- Item versioning is not supported.
- The Document ribbon item options E-mail a Link and Download a Copy do not work properly.
- The Video Library Upload Media File and New Media File Link options will use the default Document Library upload page, not the customized Video Library page with the link to supported file types. The functionality is the same.
See more release notes for each version:
Export a file from the File Share Library to the network fails
SYMPTOM
You uploaded a file to a File Share Library using the SharePoint interface. You want to export the file to the network file location, but when you select Export from the context menu of the item, you see an error like this:

CAUSE
If this happens if the account that is configured for the File Share Library does not have the permission to write to the network file location.
RESOLUTION
Be sure that the domain account you have used to configure the File Share Library Account Settings has the ability to write to the network file location.
$keywords: File Share Library
$keywords: Export

Error Log Files
Applies To
- Bamboo Products
- Windows SharePoint Services v3 and Microsoft Office SharePoint Server 2007
- SharePoint Foundation 2010 and SharePoint Server 2010
- SharePoint Foundation 2013 and SharePoint Server 2013—Standard Edition
- SharePoint Server 2016
While troubleshooting issues, the Bamboo support team may request a copy of the log files for your Bamboo product(s). Many licensing, functionality and access issue information is captured in the log files found in the BambooSolutions file folder.
This directory is located at C:WindowsTempBambooSolutions
The log files are named in this format: bsc_bamboo_{processID}.log
- where {processID} is the ID of the w3wp.exe process which was handling the request at the time of the error
NOTE: These files will be created on any farm server running the Microsoft SharePoint Foundation Web Application (on SharePoint 2010 or SharePoint 2013) or the Windows SharePoint Services Web Application (on SharePoint 2007).
To determine which servers on the farm run these services:
SharePoint 2007:
- Go to the page Central Administration > Operations > Servers in Farm
SharePoint 2010:
- Go to the page Go to the page Central Administration > System Settings > Manage Servers in this Farm
SharePoint 2013:
- Go to the page Central Administration > System Settings > Manage Servers in this Farm
There may be many log files. When reporting a problem to support, attach the most recent file(s) to your support ticket. If you know the time at which the error occurred, choose the file with the corresponding date/time.
Refer to Topology and Services in SharePoint Central Administration for a list of servers running this service. Learn more…