Installing a Bamboo application

Installing a Bamboo application

NOTE: Installation of the List Bulk Import or Bulk Export application requires administrative rights on the computer that the program is installed on. Before installing List Bulk Import or List Bulk Export, make sure you have .NET 3.5 Framework installed. If you have an earlier . NET version, the Installer will automatically detect it, and ask you to download the latest version. You cannot install the application until you have installed .NET 3.5.

To install the application, follow these steps:

Step Action
1. Download the self-extracting product EXE from the storefront and save it to a local folder on the PC or server where you want to install the application.
Double-click the product EXE file to extract the contents of the product download. The Setup program will automatically start. See below for a screenshot of the List Bulk Import setup. The List Bulk Export setup is similar.

bulk import setup.jpg
To start the Setup program manually, double-click the Setup.bat file in the root of the folder where the product files were extracted.

2.

If you are planning to import data into a SharePoint Online site (via Office365), make sure you have the Windows Identity Foundation installed. If this is not in your plans, skip this step.

NOTE: Support for importing into SharePoint Online was a new feature in List Bulk Import Release 2.5. If you don’t see the Windows Identity Foundation component listed, you may have an earlier release. List Bulk Export does not support exporting from SharePoint Online, so you won’t see this component in that install.

When you highlight the Windows Identity Foundation component in the Setup, a link to a download from Microsoft is shown on the right side of the screen (see below).

prerequisite.jpg

3.

Highlight the List Bulk Import component in the Setup and review the Installation Location and Required Installation Permissions on the right side of the screen.

When you are ready to install, click Install.

bulk import location and permissions.jpg
The installation will begin.

4. Click Next on the first page.

HW18InstallationWizard1.jpg

5. Choose the folder to install to and whether you want to install it for your use only or for everyone. Click Next.

HW18InstallationWizard2.jpg

6. In the Confirm Installation window, click Next.

HW18InstallationWizard3.jpg

7. In the Installation Complete window, click Close to exit the installation wizard.

HW18InstallationWizard4.jpg

8.

To run List Bulk Import or List Bulk Export, click the icon on your desktop, or access it from Start Menu > All Programs.

NOTE: Until you license your application with a valid license key, you will be restricted to importing or exporting only 15 items each time. See Installing the Bamboo License Manage 2.9 for more information about installing the License Manager and licensing your application.

Installing the Bamboo Attachment Cleanup Application

Installing the Bamboo Attachment Cleanup Application

For more information using the Cleanup Application, see How to Cleanup and Schedule Cleanup.

When List Bulk Import runs an update on a list that contains attachments, it must replace all of the attachments for each item whether the attachment has been updated or not as List Bulk Import has no way of knowing if the attachment has been updated or not.

For those users using Bulk Import as a data syncing tool, this causes the primary recycle bin to fill up quickly and inflate the database size. The List Bulk Import has a configuration parameter to log when attached files are removed during the import process. The resulting log file includes information about attachments were deleted/replaced. This Attachment Cleanup Application reads the log file and moves those deleted items from the primary recycle bin to the secondary recycle bin which is managed by the Site Collection Administrator.

Like List Bulk Import, the Attachment Cleanup Application can be scheduled using Windows Task Scheduler or run manually from the application itself.

Icon-WarningIMPORTANT: use recylce util.pngIn order to leverage this utility, you must run the import with the Use Bamboo Recycle Bin Cleanup program on the server to clean up deleted list attachments configuration (see screen shot). Otherwise, the attachment log file isn’t created and this utility won’t have the information it needs to run.

HW18 Attachment Cleanup install.pngThe application is installed from the List Bulk Import Setup program, shown here.

NOTE: This component can only be installed on a SharePoint server under an administrator account. If you run the List Bulk Import Setup on a PC rather than a SharePoint WFE Server, this Optional Item will NOT appear in the Components list.

To install, follow these steps:

Step Action
1.

Attachment cleanup install1.pngHighlight the Attachment Clean-up for SharePoint item in the Components list of the List Bulk Import Setup.

Click Install.

2. Attachment cleanup install2.pngIdentify the folder to install to and click Next >.
3. Attachment cleanup install3.pngConfirm the location and click Next >. The installation will progress.
4. Attachment cleanup install4.pngWhen the installation is complete, click Close to close the installation application.

cleanup desktop icon.pngYou should see an icon for the application on your Desktop when the installation completes.

Import Data from One SharePoint Environment to Another

Import Data from One SharePoint Environment to Another

Overview of Import Options

To import data from a delimited text file or Excel spreadsheet to a SharePoint list or library, follow these steps:

Step Action
1. Connect to the Target Site. See How to Connect to the Target Site for more information.
2. HW18 create Import Job.pngIn the Import Tool section of the dashboard, select Create Import Job.
3. Select Existing SharePoint List. Like you did when specifying your Target SharePoint environment, enter the Source site URL, SharePoint Version, and Login Account.

Sp to SP import.png

When ready, click Next to continue.
4.

On the Source Information tab, select the List or Library and View containing the items to be imported.

Sp to SP import - source info.png

Select the Import Options:

import content types snip.png

  • Import Content Types. Check the box to display the available content types from the source list. Then select/highlight the content types that you want to create during the import to your target list.

    Icon-WarningIMPORTANT: The List Bulk Import can create content types only if the source and target lists are in the same site collection.

    source columns to be imported1.png

  • Select source columns to be imported to a single target list column. When importing files to a documentation library or list, the import process creates new items in the target list/library. As such, the SharePoint default columns of Created, Created By, Modified, and Modified by will be based on the date the file is imported and the user who ran the import. If you want to transfer information about when the file was uploaded to the Source list, it cannot be copied to the Created column in the target list. Instead, you can copy that date (and the other available column listed) to another column in the target list/library. The selected source columns will be concatenated and available as a Source Column in the Map the Columns page (Step 6 below). See screen shot at right where all four available source columns were checked.

    Icon-WarningIMPORTANT: You cannot specify a folder as part of the source or target destination. You can choose the folder to import from or to in the Map the Columns page (see Step 6 below).

5.

Once the Source Information is specified, click the Target Information tab and select the list or library in the Target Site to import to. All available lists and libraries are shown in the drop-down menu. Once selected, the menu is populated with available lists and libraries found within the specified site.

NOTE: If the list or library is not shown, see Reset the Connection to the Target SharePoint Site to refresh the list.

Sp to SP import - target info.png

Icon-WarningIMPORTANT: You cannot specify a folder as part of the source or target destination. You can choose the folder to import from or to in the Map the Columns page (see Step 6 below).

6.

Map the Source and Target Columns. After selecting the Source Information and Target Information, click Next to begin mapping source columns to the target site.

Sp to SP import - map the columns1.png

  1. In the Target Columns column, all the fields from the selected target list are shown. Required columns are marked with an (*). Click Clear to clear all the selections in this column if you prefer to select them individually.
  2. The Source Columns column shows the fields from the source data file. If you have noted that the first row contains column headings, you will see the heading name. Otherwise, you will see generic names for the fields. Choose the Source Column from the drop down that you want imported to the corresponding Target Column.

    NOTE: If you do not have data for a particular Target Column, leave the selection set to None. List Bulk Import will map fields with the same names automatically (see the Title column in the screen shot above). You can choose to keep these maps or change them.

  3. The Sample Source Data will show the Source Column value for the first row to be imported. Use this information to ensure that you chose the correct Source Column.

    NOTE: This page usually has a vertical scroll bar to accommodate all the fields.

When finished, click Next.

7. If you are importing any data to a Lookup column, the next page will allow you to map values from your source data to the available choices in your target list. See How to Map Values to Lookup or Choice Columns.
8. Check for duplicates. If you have existing information in your target list and are concerned that you may have duplicate information, see How to Check for Duplicate Records. Otherwise, don’t bother checking for duplicates; it slows down the import.
9.

Review and Import. If you think you may want to run this import again, save your configuration parameters in a template file. See Save the Import Configuration for more information.

Otherwise, click Import to start the import.

10. When the import completes, click View Log to review the import. See How to Review the Log File for more information.

Import Data from SQL Server to SharePoint

Import Data from SQL Server to SharePoint

Overview of Import Options

This page describes how to import data from a SQL Server database through an ODBC connection into a SharePoint List using
List Bulk Import.

Step Action
1. Connect to the Target Site. If you aren’t connected to the desired site, see Reset the Connection to the Target SharePoint Site.
2. sql start2.pngIn the Import Tool section of the dashboard, click Create Import Job.
3.

import from SQL.pngOn the Location of Source Data page, choose SQL Server (ODBC Driver).

ODBC data source configured on my pc.png

When that choice is selected, you will see the Select User Data Source selection list.

Icon-WarningIMPORTANT: The Select User Data Source list will include all the ODBC data sources that are configured with the SQL Server driver on the PC where you are running the List Bulk Import. This import tool doesn’t support other ODBC drivers at this time.

Choose the data source that contains the data you want to import into SharePoint and then click Next.

4. sql.pngOn the Source Information tab of the Specify Source and Target page, select the Table or View that contains the data to be imported.
sql target.png

On the Target Information tab of the Specify Source and Target page, select the SharePoint list or library where you want the data to be imported to.

5.

sql map the columns.pngOn the Map the Columns page, map columns from the SQL Table or View to the columns available in the selected SharePoint list.

NOTE: It isn’t necessary to map all columns. If there is no source or target column for some data, leave the selection set to None.

6.

sql Map Values.pngOn the Map the Values page, map any choice or lookup column values. See How to Map Values to Lookup or Choice Columns for more information.

NOTE: If the list or library columns you are importing to don’t include a lookup or choice column, you may see a page that looks similar to the one shown here.

7.

SQL Check for Dups.pngOn the Check for Duplication page, decide if you want to check for duplicates. see How to Check for Duplicate Records.

Otherwise, don’t bother checking for duplicates; it slows the import.

When ready, click Next to continue.

8.

sql start import.pngOn the Review and Import page, review the import configuration.

If you want to save your configuration parameters in the Import Job Deployment area of the page, please see Save the Import Configuration for more information.

When ready, click Import to start the import.

Icon-Tip If you don’t want to import at this time, save your configuration parameters and schedule the import to run later. See Schedule an Import to Run Unattended.

9. The progress of the import will be displayed on the page. When it completes, you can review the results. See Review the results with the Log Viewer for more information.

Import Data from Excel or Delimited Text File to SharePoint List

Import Data from Excel or Delimited Text File to SharePoint List

Overview of Import Options

To import data from a delimited text file or Excel spreadsheet, follow these steps:

Step Action
1. Connect to the Target Site. If you aren’t connected to the desired site, see Reset the Connection to the Target SharePoint Site.
2. HW18_CreateJob.jpgIn the Import Tool section of the dashboard, select Create Import Job.
3.

HW18_SelectExcel.jpgSelect Excel or delimited text file and click Next.

NOTE: To import a Microsoft Excel File, Microsoft Excel must be installed on the PC. If your computer is running 32-bit Windows, List Bulk Import supports the 32-bit version of Excel 2007 or Excel 2010. If your computer is running 64-bit Windows, List Bulk Import supports the 64-bit version of Excel 2010 only.

4.

On the Source Information tab, enter the file path in the text box or click Browse to browse to the file containing the file to be imported.

HW18_SourceInfo.jpg
Choosing a Microsoft Excel file (*.xls or *.xlsx) requires the following Import File Information:

import from xls with highlight.png

  • Sheet Name – Users must choose the Sheet in the Excel workbook that contains the data to import
  • First row contains column headings – Check this box to indicate that the first row contains column headings and not data
  • Transpose selected Excel Sheet – Check this box to transpose the previously referenced Excel sheet. Users are prompted to enter the Starting Cell and Ending Cell when this option is selected.

    HW18_XLSImportInfo.jpg

NOTE: Choosing to transpose the Excel Sheet rotates the selected Excel Sheet (i.e. Column A will become Row 1, Column B will become Row 2 and so on) prior to the import process. The pivoting cell is defined by the Starting Cell; thus, if D4 is the Starting Cell, Column D becomes row 4.

Choosing a Comma Separated Variable (CSV) or Text (.txt) File requires the following Import File Information:

Import from txt with highlight.png

  • Field Separator – If the file selected is a CSV file, this is set to Comma(.) by default. Otherwise, select the appropriate choice for your data
  • Field Data Delimiter – Select the delimiter used in your data file. This option is especially useful with CSV files because data often has commas in numeric values and using a delimiter will ensure that the comma is included in the data rather than used as a field delimiter.
  • First row contains column headings – Check this box to indicate that the first row contains column headings and not data.
5.

Once the Source Information is specified, click the Target Information tab and select the list or library in the Target Site to import to. All available lists and libraries are shown in the drop-down menu. Once selected, the menu is populated with available lists and libraries found within the specified site.

NOTE: If the list or library is not shown, see Reset the Connection to the Target SharePoint Site to refresh the list.

HW18 target info page.png
6.

Map the Source and Target Columns. After selecting the Source Information and Target Information, click Next to begin mapping source columns to the target site.

HW18  Map the source and target.png

  1. All the fields from the selected target list are shown in the Target Columns column. Required columns are marked with an (*). Click Clear to clear all the selections in this column if you prefer to select them individually.

    If you want to import a file as an attachment to a list item, select the Target column called Attachments and map it to the column in your source data that includes the filename AND path.

    import file attachment.png
    sample import file.png
  2. The Source Columns column shows the fields from the source data file. If you have noted that the first row contains column headings, you will see the heading name. Otherwise, you will see generic names for the fields. Choose the Source Column from the drop down that you want imported to the corresponding Target Column.

    NOTE: If you do not have data for a particular Target Column, leave the selection set to None. List Bulk Import will map fields with the same names automatically (see the Title column in the screen shot above). You can choose to keep these maps or change them.

  3. The Sample Source Data will show the Source Column value for the first row to be imported. Use this information to ensure that you chose the correct Source Column.

    NOTE: This page usually has a vertical scroll bar to accommodate all the fields.

When finished, click Next.

7. If you are importing any data to a Lookup column, the next page will allow you to map values from your source data to the available choices in your target list. See How to Map Values to Lookup or Choice Columns.
8.

Check for duplicates. If you have existing information in your target list and are concerned about importing duplicate information, see How to Check for Duplicate Records. Otherwise, don’t bother checking for duplicates; it slows down the import.

Icon-Tip If the intent of your import is to update existing items and replace the attached files, choose to check for duplicates and then choose to update existing records. See How to Check for Duplicate Records.

9.

Review and Import. If you think you may want to run this import again, save your configuration parameters in a template file. See Save the Import Configuration for more information.

Otherwise, click Import to start the import.

10. When the import completes, click View Log to review the import. You can also review the results later since the log file is saved. See Review the results with the Log Viewer for more information.

Import Content Types

Import Content Types

When migrating content from SharePoint to SharePoint, you can import content types if the Source and Target are in the same site collection.
contenttypes.png

1. In the Migration Tab check the Copy List Content Types link to display the available content types from the source list.
2. Then select/highlight the content types that you want to create during the import to your target list.

How to find the version of your List Bulk Import Application

How to find the version of your List Bulk Import Application

If you run into an issue and contact our Customer Support Team, they may ask you about the version of the List Bulk Import you are using.

To find the version, follow these steps:

Step Action
1. From the main menu, click Help > About Bulk Import

HW18 about.png
2.

In the screen that appears (see below), find the Bamboo BulkImport Version and File Version. Support Engineers are generally interested in knowing the File Version you have installed.

HW18 About2.png

Check the Release Notes for information about features that may have been added to the product since the version you are using.

How to Clean Up Files Stored in the Target SharePoint Site’s Recycle Bin Using the Bamboo Attachment Clean Up Application

How to Clean Up Files Stored in the Target SharePoint Site’s Recycle Bin Using the Bamboo Attachment Clean Up Application

When List Bulk Import runs an update on a list that contains attachments, it must replace all of the attachments for each item whether the attachment has been updated or not as List Bulk Import has no way of knowing if the attachment has been updated or not. For those users using List Bulk Import as a data syncing tool, this causes the primary recycle bin to fill up quickly and inflate the database size.

The Bamboo Attachment Cleanup Application uses a log file created during the import process to identify which attachments were deleted/replaced, and then move the deleted items from the primary recycle bin to the secondary recycle bin, which is managed by the Site Collection Administrator. Like List Bulk Import, the clean up process can be scheduled using Windows Task Scheduler to run unattended or run manually from one of the SharePoint WFE servers.

NOTE: Once the clean up process runs, the file extension of the deleted attachments log file is automatically changed to .BAK.

Step Action Result
1.

Double-click the Bamboo Attachment Clean Up Application icon on your server desktop. Alternatively, select Programs from your Windows Start Menu and then Bamboo Attachment Clean Up Application.

If you don’t see the icon or the program, see Installing the Bamboo Attachment Cleanup Application to install it.

The Attachment Clean-Up Application starts.

HW18_CleanUpApp.jpg
2.

If you have previously save a configuration file, open it by selecting File > Open Config File from the main menu. The configuration files are typically saved in the following folder where the application is installed:

C:/Program Files/Bamboo Solutions Corporation/Bamboo Attachment Clean Up Application/ScheduleFiles
3. Site URL. Enter the URL for the site where the import process was run. The deleted file(s) from the import/update process should reside in the Recycle Bin of this site. When ready, click Connect.
4.

Deleted Log File Name. Type in the location and file name of the deleted attachments log file, or click Browse to locate the file.

NOTE: The log file is the xml file you opted to create in List Bulk Import on the Check for Duplicate Records page. In the List Bulk Import application, you must check the option to use the Bamboo Attachment Clean Up application and enter a UNC path to the server where you want to save the log file. The application gives the file a name, in this format:

Bamboo.Log.DeletedFile952014_42510_PM.xml

Where the 952014_42510_PM represents the time and date the log file was created.

5. Config File Name. If you want to save this cleanup configuration in an XML file so you can schedule it to run unattended using Windows Task Scheduler, type in a configuration file name, and click Save. See Schedule the Cleanup Application to Run Unattended for more information and then click Exit to close the application.
6.

If you prefer to run the utility manually, click Clean when ready to start the cleanup process. All the files that were removed from the primary recycle bin are listed in the Attachments File for Cleaning box (see screenshot above).

NOTE: Clean up uses the same log viewer as is used for Bulk Import.

7. Click Exit to close the application.

How to Check for Duplicate Records

How to Check for Duplicate Records

Overview of Import Options

To check for duplicate records during an import, review the instructions below.

HW18 - Check for dups with letters.png

Step Action
A.

Make sure the Check For Record Duplication box is checked.

NOTE: If you don’t need to check for duplicates, don’t check this box. It will slow down the import process. It is unchecked by default.

B.

Next, select one or more columns that determine if a record is a duplicate. For example, when importing contacts to a contacts list, you may choose to check the email address to determine if a record is a duplicate. In that case, highlight the email address column in the Available Columns list and move it to the Selected Columns list by clicking the right arrow in the middle of the two lists.

NOTE: If the target is a Picture or Document Library, users can only check for duplication based on the target column Name, which is the file name because a file with the same name cannot be imported twice to the same library.

C.

Once the columns that determine uniqueness are in the Selected Columns list, decide whether to Skip duplicate records or Update existing records with data from source list.

Icon-WarningIMPORTANT: When updating items with attachments, the current attachments are removed and the files in the source file replace them.
For example, consider using the sample import file shown below. If the list item called Green title exists with an existing attachment called Sample1.docx, the import/update process will remove the existing attachment called Sample1.docx and replace it with a file called green.jpg.

sample import file.png

Icon-Tip If you select Update existing records with data from the source list and you are importing to a SharePoint list (not a library) with attachments, choose Use Bamboo Recycle Bin Cleanup program on the server to clean up deleted list attachments and enter the UNC path where the log file will be stored on the SharePoint WFE server where the Cleanup Application will run. Select this option in order to use the Clean-up Application to move files from the site’s recycle bin to the site collection’s recycle bin; thus, saving valuable database space. For additional information, refer to How to Clean Up Files Stored in the Target SharePoint Site’s Recycle Bin.

Update existing records1.png

Once all of the columns are selected and the duplication rule is set, click Next.

Overview of Import Options

Highlights of User Directory

Highlights of User Directory

UserDirectory.pngMany companies use Active Directory Services to manage their users. With the addition of SharePoint, another user directory database has been introduced – the User Profile Database. But even with SharePoint features such as Single Sign On, and automatic importing of Active Directory profile information to SharePoint, the bulk of the workload to maintain user information is still on the Administrator. What is lacking is a way to allow the owners of the user information to maintain it themselves, both safely and securely, using either database as their directory service source.

Bamboo’s User Directory provides an easy to use, SharePoint-based, self-service directory that allows users to maintain user information in the SharePoint User Profile Database or Active Directory.

  • View your user organization in a user-friendly tree view by organization chart or alphabetical order by last name.
  • Users can view all profiles but can only edit their own depending on permissions set up for the type of directory service selected.

With the ability to view, search and print user profile information (such as resume or skill set), your directory services now provide value to your users as well as your entire company.

Deactivating the license for a Bamboo Desktop application

Deactivating the license for a Bamboo Desktop application

Bamboo Desktop applications (i.e., List Bulk Import, List Bulk Export) are activated using the Bamboo License Manager. See Activating a Bamboo Desktop Product Using the License Manager for more information.

It is not possible to deactivate a license with the Bamboo License Manager. Because licenses can be activated on only one PC at a time, you will need to deactivate a license if you wish to use it on another PC. To deactivate a license for a Bamboo Desktop application, follow these steps:

If your SharePoint WFE server does not have Internet access, you will not be able to deactivate a Bamboo product license from Central Administration. Instead, you can access the My Bamboo area of the Bamboo Solutions web site to deactivate any Bamboo product license key.

Follow the steps below:

Step Action
1. Determine the license key you want to move or deactivate. Go to the PC where it is activated and run the Bamboo License Manager.

LM2.9activate1.jpg

2. Click the Browse button and browse for the *.exe file for the licensed application.

LM2.9activate2.jpg

3. The application will appear in the drop down selection.

LM2.9activate3.jpg
Leaving the Enter valid License key box blank, click Activate.

4. The License Status will be displayed.

LM2.9activate4.jpg
Click Deactivate to deactivate the license key. Once it is deactivated, you can use it on another PC.

Create an ODBC Connection

Create an ODBC Connection

Prior to creating an import job follow the steps described herein to create an ODBC connection:

Step Action Result
1. Open the ODBC Administrator by clicking Start Menu > Control Panel > Additional Options > Data Connection (ODBC).
2. Click Add. ODBC.jpg
3. In the Create New Data Source window, select SQL Server from the list.
4. Click Finish.
5. Type a name of the data source in the Name field.
6. Type a description of the data source in the Description field.
7. Select the server from the Server drop-down menu. ODBC2.jpg
8. Choose the authentication method for the SQL Server.
9. Click Next. ODBC3.jpg
10. Ensure the Change the default database to box is checked.
11. Select the database where the source data is located.
12. Click Next.
13. On the following screen make no changes and click Finish.
14. Click Test Data Source to confirm connectivity to the SQL Server.

ODBC4.jpg

Note: A successful test returns the message: TESTS COMPLETED SUCCESSFULLY!

Connect to a Local Source

Connect to a Local Source

Overview of Importing

Select the type of local Source Type from the dropdown, then click Browse to locate the file containing the file to be imported.

xls, xlsx Files

Note: To import a Microsoft Excel File, Microsoft Excel must be installed. If your computer is running 32-bit Windows, List Bulk Import supports the 32-bit version of Microsoft Excel. If your computer is running 64-bit Windows, List Bulk Import supports the 64-bit version of Microsoft Excel.

Choosing a Microsoft Excel file (*.xls or *.xlsx) requires the following Import File Information:

  • Sheet Name: Users must choose the Sheet in the Excel workbook that contains the data to import.
  • First Row Contains Column Headings: Check this box to indicate that the first row contains column headings and not data.
  • Transpose Selected Excel Sheet: Check this box to transpose the previously referenced Excel sheet. You are prompted to enter the Starting Cell and Ending Cell when this option is selected.

xls.png

csv, txt Files

Choosing a CSV file (*.csv or *.txt) requires the following File Information:

  • Field Separator: If the file selected is a CSV file, this is set to Comma(,) by default. Otherwise, select the appropriate choice for your data.
  • Field Data Delimiter: Select the delimiter used in your data file. This option is especially useful with CSV files because data often has commas in numeric values and using a delimiter will ensure that the comma is included in the data rather than used as a field delimiter.
  • First Row Contains Column Headings: Check this box to indicate that the first row contains column headings and not data.

csv.png

Local or Network File Directory

Migrating a Local or Network File Directory allows you to replicate the file structure and content to a Sharepoint Library. Additional configuration options are available under the migration tab in Migrate a Local File Directory.
csv.png

Next: Connect to Target Site

Overview of Importing

Connect to a SharePoint Source

Connect to a SharePoint Source

Overview of Importing

To connect to a SharePoint source specify your SharePoint version, site URL, authentication, and login credentials.

source.png

Entering the URL of a specific list or library will automatically select that list or library for migration in the migration tab. Otherwise, you can use a menu in the migration tab to select a specific list/library from the site or site collection.

Next: Connect to Target Site

Overview of Importing

Complementary Products for Bulk Import

Complementary Products for Bulk Import

sharepointsolutions.pngYou will find many of our products complement each other quite nicely saving you the time and trouble to write custom code. With Bamboo at the heart of your SharePoint investment, you gain access to a huge catalog of enhancements, components, and accessories that add the critical functionality your business requires.

The same components can be easily used in future applications and they all come from a single, trusted vendor, ensuring an easy purchase process and support you can count on. That’s the Bamboo Way!


Checking the status of a Bamboo Desktop application trial

Checking the status of a Bamboo Desktop application trial

Overview of Licensing and and Product Activation

Follow the steps below to check the status of your Bamboo Desktop product trial using the Bamboo License Manager.

NOTE: In order to check the trial status, you need to install the Bamboo License Manager. Please see Installing the Bamboo License Manager 2.9 for more information.

To check the trial status, follow these steps:

Step Action
1. From the shortcut on your Desktop, start the Bamboo License Manager. The screen shown below will appear.
LM2.9activate1.jpg

Click the Browse button to browse for the desired product.
2. If you installed the product in the default location, there should be a product folder in C:Program filesBamboo Solutions Corporation.
LM2.9activate2.jpg

Locate the *.exe file for the product. For example, the *.exe file for Bamboo List Bulk Import, is Bamboo.BulkImport.exe as shown in the screen shot above.
3. You are returned to the License Manager and the appropriate product name appears in the drop down selection.

LM2.9activate3.jpg

Leave the space for the valid License Key blank and click Activate.
4. The License Status screen will appear letting you know the status of the license.

LM2.9trialstatus.jpg